You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-block/mbuffer/mbuffer-20171011.ebuild

60 lines
1.4 KiB

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
DESCRIPTION="M(easuring)buffer is a replacement for buffer with additional functionality"
HOMEPAGE="http://www.maier-komor.de/mbuffer.html"
SRC_URI="http://www.maier-komor.de/software/mbuffer/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="debug ssl test"
RESTRICT="!test? ( test )"
RDEPEND="ssl? ( dev-libs/openssl:0= )"
DEPEND="${RDEPEND}
test? ( dev-libs/openssl:0 )"
PATCHES=(
"${FILESDIR}/${PN}-20171011-resolv-multi-order-issue.patch"
"${FILESDIR}/${PN}-20171011-sysconfdir.patch"
)
src_prepare() {
ln -s "${DISTDIR}"/${P}.tgz test.tar #258881
# Enforce MAKEOPTS=-j1 because src_test() spawns multiple listener
# using same port and src_install may have problems (with /etc folder)
export MAKEOPTS=-j1
default
}
src_configure() {
local myeconfargs=(
$(use_enable ssl md5)
$(use_enable debug)
)
econf "${myeconfargs[@]}"
}
src_test() {
if has usersandbox ${FEATURES} || has network-sandbox ${FEATURES}; then
ewarn "Some tests may fail with FEATURES=usersandbox or"
ewarn "FEATURES=network-sandbox; Skipping tests because"
ewarn "test suite would hang forever in such environments!"
return 0;
fi
default
}
pkg_postinst() {
if ! has_version "app-arch/mt-st"; then
elog ""
elog "If you want autoloader support you need to install \"app-arch/mt-st\" in addition!"
fi
}