You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-power/acpi_call/acpi_call-3.17.ebuild

38 lines
804 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
inherit linux-info linux-mod
HOMEPAGE="https://github.com/teleshoes/acpi_call"
if [ "${PV}" = "9999" ]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
KEYWORDS=""
else
inherit vcs-snapshot
SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
fi
DESCRIPTION="A kernel module that enables you to call ACPI methods"
LICENSE="GPL-2"
SLOT="0"
IUSE=""
CONFIG_CHECK="ACPI"
MODULE_NAMES="acpi_call(misc:${S})"
BUILD_TARGETS="default"
PATCHES=(
"${FILESDIR}/${P}-linux-4.12.patch"
"${FILESDIR}/${P}-linux-4.14.patch"
)
src_compile(){
BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
linux-mod_src_compile
}