You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-process/uksmd/uksmd-0_pre20190726.ebuild

36 lines
759 B

# Copyright 2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit linux-info systemd
MY_COMMIT="42f4ff8eb09011bf1a199938aa2afe23040d7faf"
MY_P="${PN}-${MY_COMMIT}"
DESCRIPTION="Userspace KSM helper daemon"
HOMEPAGE="https://gitlab.com/post-factum/uksmd"
SRC_URI="https://gitlab.com/post-factum/uksmd/-/archive/${MY_COMMIT}/${MY_P}.tar.bz2 -> ${P}.tar.bz2"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="sys-process/procps:=
sys-kernel/pf-sources:*"
RDEPEND="${DEPEND}"
CONFIG_CHECK="KSM"
S="${WORKDIR}/${MY_P}"
PATCHES=( "${FILESDIR}/${P}-respect-cflags-ldflags.patch" )
src_install() {
default
einstalldocs
newinitd "${FILESDIR}/uksmd.init" uksmd
systemd_dounit distro/uksmd.service
}