You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/virtual/python-cffi/python-cffi-0.ebuild

18 lines
576 B

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
inherit python-r1
DESCRIPTION="A virtual for the Python cffi package"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# built-in in PyPy and PyPy3
RDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep 'dev-python/cffi[${PYTHON_USEDEP}]' 'python*')"