You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/www-apps/jekyll-coffeescript/jekyll-coffeescript-1.2.2.e...

33 lines
843 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
USE_RUBY="ruby24 ruby25"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
RUBY_FAKEGEM_EXTRADOC="README.md History.markdown"
RUBY_FAKEGEM_TASK_DOC=""
inherit ruby-fakegem
SRC_URI="https://github.com/jekyll/jekyll-coffeescript/archive/v${PV}.tar.gz -> ${P}.tar.gz"
DESCRIPTION="A CoffeeScript Converter for Jekyll"
HOMEPAGE="https://github.com/jekyll/jekyll-coffeescript"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"
all_ruby_prepare() {
sed -i -e '/bundler/d' Rakefile || die
sed -i -e "/^RSpec/i \
require 'jekyll'"\
-e "/^RSpec/i \
require 'jekyll-coffeescript'" spec/spec_helper.rb || die
}
ruby_add_rdepend ">=dev-ruby/coffee-script-2.2
>=dev-ruby/coffee-script-source-1.12"
ruby_add_bdepend "test? ( www-apps/jekyll )"