You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-libs/gtkglarea/gtkglarea-2.1.0.ebuild

47 lines
976 B

# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
GCONF_DEBUG="no"
inherit gnome2
DESCRIPTION="OpenGL canvas and context provider for GTK+"
HOMEPAGE="https://www.mono-project.com/archived/gtkglarea/"
LICENSE="LGPL-2+ GPL-2+" # examples are GPL-2+, library is LGPL-2+
SLOT="2"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-linux ~x86-linux"
IUSE="examples"
RDEPEND="
>=x11-libs/gtk+-2.22:2
virtual/opengl
"
DEPEND="${RDEPEND}
virtual/pkgconfig
"
src_prepare() {
# Do not build examples
sed -e "s:\(SUBDIRS.*\)examples:\1:" \
-i Makefile.am Makefile.in || die "sed 1 failed"
gnome2_src_prepare
}
src_configure() {
gnome2_src_configure --disable-static
}
src_install() {
DOCS="AUTHORS ChangeLog NEWS README* docs/*.txt"
gnome2_src_install
if use examples; then
cd "${S}"/examples
insinto /usr/share/doc/${PF}/examples
doins *.c *.h *.lwo README
fi
}