You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/unclutter-xfixes/unclutter-xfixes-1.5-r1.ebuild

32 lines
608 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="A rewrite of unclutter using the x11-xfixes extension"
HOMEPAGE="https://github.com/Airblader/unclutter-xfixes"
SRC_URI="https://github.com/Airblader/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-libs/libev
x11-libs/libX11
x11-libs/libXfixes
x11-libs/libXi
!x11-misc/unclutter
"
DEPEND="${RDEPEND}"
BDEPEND="
app-text/asciidoc
virtual/pkgconfig
"
src_compile() {
emake CC="$(tc-getCC)"
}