You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-terms/guake/guake-3.3.2.ebuild

62 lines
1.3 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python3_6 )
DISTUTILS_SINGLE_IMPL=1
inherit distutils-r1 gnome2-utils xdg-utils
DESCRIPTION="Drop-down terminal for GNOME"
HOMEPAGE="https://github.com/Guake/guake https://pypi.org/project/Guake"
SRC_URI="mirror://pypi/G/${PN^}/${P^}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm x86"
IUSE="utempter"
RDEPEND="
dev-libs/keybinder:3
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/pbr[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
x11-libs/libnotify
x11-libs/vte:2.91
utempter? ( sys-libs/libutempter )
"
DEPEND="
${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
sys-devel/gettext
sys-devel/make
"
PATCHES=(
"${FILESDIR}"/${PN}-3.3.2-paths.patch
)
S=${WORKDIR}/${P^}
python_compile_all() {
emake prepare-install prefix=/usr
emake generate-paths prefix=/usr DATA_DIR='$(datadir)/guake' DEV_SCHEMA_DIR='$(gsettingsschemadir)'
default
}
python_install_all() {
emake install-schemas install-locale prefix=/usr DESTDIR="${D}"
distutils-r1_python_install_all
}
pkg_postinst() {
gnome2_schemas_update
xdg_desktop_database_update
}
pkg_postrm() {
gnome2_schemas_update
xdg_desktop_database_update
}