You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-arch/cpio/cpio-2.15.ebuild

55 lines
1.2 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit multiprocessing
DESCRIPTION="File archival tool which can also read and write tar files"
HOMEPAGE="https://www.gnu.org/software/cpio/cpio.html"
SRC_URI="mirror://gnu/cpio/${P}.tar.bz2"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
IUSE="nls"
PDEPEND="
app-alternatives/cpio
"
PATCHES=(
"${FILESDIR}"/${PN}-2.12-non-gnu-compilers.patch # bug #275295
)
QA_CONFIG_IMPL_DECL_SKIP=(
unreachable
MIN
alignof
static_assert
)
src_configure() {
local myeconfargs=(
$(use_enable nls)
--bindir="${EPREFIX}"/bin
--with-rmt="${EPREFIX}"/usr/sbin/rmt
# install as gcpio for better compatibility with non-GNU userland
--program-prefix=g
)
econf "${myeconfargs[@]}"
}
src_test() {
emake check TESTSUITEFLAGS="--jobs=$(get_makeopts_jobs)"
}
pkg_postinst() {
# Ensure to preserve the symlink before app-alternatives/cpio
# is installed
if [[ ! -h ${EROOT}/bin/cpio ]]; then
ln -s gcpio "${EROOT}/bin/cpio" || die
fi
}