You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-crypt/md6sum/md6sum-1.0-r2.ebuild

25 lines
519 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic
DESCRIPTION="A C implementation of MD6"
HOMEPAGE="https://groups.csail.mit.edu/cis/md6"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
PATCHES=(
"${FILESDIR}/${P}-ldflags.patch"
"${FILESDIR}/${P}-cflags.patch"
"${FILESDIR}/${P}-format-security.patch"
)
src_configure() {
append-cflags -fcommon # bug #706780
default
}