You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-crypt/minisign/minisign-0.11-r1.ebuild

35 lines
640 B

# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake
DESCRIPTION="Dead simple tool to sign files and verify signatures"
HOMEPAGE="https://github.com/jedisct1/minisign/"
SRC_URI="
https://github.com/jedisct1/minisign/archive/${PV}.tar.gz
-> ${P}.tar.gz
"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
DEPEND="
dev-libs/libsodium:=[-minimal(-)]
"
RDEPEND="
${DEPEND}
"
BDEPEND="
virtual/pkgconfig
"
src_configure() {
local mycmakeargs=(
-DCMAKE_STRIP=OFF
)
cmake_src_configure
}