You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-crypt/nasty/nasty-0.6-r2.ebuild

29 lines
535 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Proof-of-concept GPG passphrase recovery tool"
HOMEPAGE="http://www.vanheusden.com/nasty/"
SRC_URI="http://www.vanheusden.com/nasty/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="app-crypt/gpgme:="
DEPEND="${RDEPEND}"
PATCHES=( "${FILESDIR}"/${P}-flags.patch )
src_compile() {
emake CC="$(tc-getCC)" DEBUG=
}
src_install() {
dobin nasty
dodoc readme.txt
}