You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emacs/muse/muse-3.20-r2.ebuild

35 lines
764 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit elisp
DESCRIPTION="An authoring and publishing environment for Emacs"
HOMEPAGE="https://www.gnu.org/software/emacs-muse/"
SRC_URI="https://github.com/alexott/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
LICENSE="GPL-3+ FDL-1.2+ GPL-2 MIT"
SLOT="0"
KEYWORDS="amd64 ppc x86"
#IUSE="test"
RESTRICT="test" #426546
#DEPEND="test? ( app-emacs/htmlize )"
SITEFILE="50${PN}-gentoo.el"
src_compile() {
emake -j1
}
src_install() {
elisp-install "${PN}" lisp/*.el lisp/*.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
doinfo texi/muse.info
dodoc AUTHORS NEWS README ChangeLog*
dodoc -r contrib etc examples experimental scripts
}