You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emacs/transient/transient-0.6.0.ebuild

43 lines
818 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit elisp
DESCRIPTION="Transient commands abstraction for GNU Emacs"
HOMEPAGE="https://magit.vc/manual/transient/
https://github.com/magit/transient/"
if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/magit/${PN}.git"
else
SRC_URI="https://github.com/magit/${PN}/archive/v${PV}.tar.gz
-> ${P}.tar.gz"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
fi
LICENSE="GPL-3+"
SLOT="0"
DOCS=( CHANGELOG README.org "docs/${PN}.org" )
ELISP_TEXINFO="docs/${PN}.texi"
SITEFILE="50${PN}-gentoo.el"
RDEPEND="
>=app-emacs/compat-29.1.4.1
"
BDEPEND="
${RDEPEND}
sys-apps/texinfo
"
src_prepare() {
mv lisp/*.el . || die
elisp_src_prepare
}