You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-emulation/softgun/softgun-0.22.ebuild

35 lines
634 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic toolchain-funcs
DESCRIPTION="ARM software emulator"
HOMEPAGE="http://softgun.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
DEPEND="media-libs/alsa-lib"
RDEPEND="${DEPEND}"
PATCHES=( "${FILESDIR}"/${PN}-0.22-make.patch )
src_configure() {
append-cflags -fcommon
default
}
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
dodir /usr/bin
emake install prefix="${D}/usr"
dodoc README configs/*.sg
}