You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/clockywock/clockywock-0.3.1a.ebuild

35 lines
595 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="ncurses based analog clock"
HOMEPAGE="https://soomka.com/clockywock"
SRC_URI="https://soomka.com/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
RDEPEND="sys-libs/ncurses:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
"
PATCHES=( "${FILESDIR}/${P}-makefile.patch" )
src_prepare() {
# Respect compiler
tc-export CXX
default_src_prepare
}
src_install() {
dobin ${PN}
doman ${PN}.7
dodoc README CREDITS
}