You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/cpipe/cpipe-3.0.3-r1.ebuild

28 lines
518 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Counting pipe, measures data transfered over pipe"
HOMEPAGE="https://github.com/HaraldKi/cpipe"
SRC_URI="https://github.com/HaraldKi/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_configure() {
tc-export CC
}
src_install() {
dobin cpipe
einstalldocs
doman cpipe.1
}