You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/ddcui/ddcui-0.5.4.ebuild

46 lines
913 B

# Copyright 2019-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Check for bumps & cleanup with app-misc/ddcutil
inherit cmake xdg
DESCRIPTION="Graphical user interface for ddcutil - control monitor settings"
HOMEPAGE="https://www.ddcutil.com/ddcui_main/"
SRC_URI="https://github.com/rockowitz/ddcui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64"
LICENSE="GPL-2+"
SLOT="0"
DEPEND="
dev-libs/glib
>=app-misc/ddcutil-2.1.3:0/5
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
"
RDEPEND="${DEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}/${PN}-0.5.3-drop-qthelp-dep.patch"
)
src_prepare() {
# move docs to correct dir
sed -i -e "s%share/doc/ddcui%share/doc/${PF}%g" CMakeLists.txt || die
cmake_src_prepare
}
src_configure() {
local mycmakeargs=(
# Not quite there yet, so force off
-DUSE_QT6=OFF
)
cmake_src_configure
}