You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/hastyhex/hastyhex-1.0.0.ebuild

24 lines
486 B

# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="A blazing fast hex dumper"
HOMEPAGE="https://github.com/skeeto/hastyhex"
SRC_URI="https://github.com/skeeto/${PN}/releases/download/v${PV}/${P}.tar.xz"
LICENSE="Unlicense"
SLOT="0"
KEYWORDS="amd64"
src_compile() {
$(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die
}
src_install() {
dobin ${PN}
doman ${PN}.1
}