You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-misc/openrgb-plugin-visualmap/openrgb-plugin-visualmap-0....

53 lines
1.3 KiB

# Copyright 2020-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qmake-utils
SRC_URI="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin/-/archive/release_${PV}/OpenRGBVisualMapPlugin-release_${PV}.tar.bz2"
S="${WORKDIR}/OpenRGBVisualMapPlugin-release_${PV}"
KEYWORDS="amd64"
DESCRIPTION="Plugin for OpenRGB to create virtual devices out of multiple real ones"
HOMEPAGE="https://gitlab.com/OpenRGBDevelopers/OpenRGBVisualMapPlugin"
LICENSE="GPL-2"
SLOT="0"
RDEPEND="
>=app-misc/openrgb-0.9:=
dev-qt/qtcore:5
dev-qt/qtgui:5
dev-qt/qtwidgets:5
"
DEPEND="
${RDEPEND}
dev-cpp/nlohmann_json
"
PATCHES=(
"${FILESDIR}/${P}-dep.patch"
)
src_prepare() {
default
rm -r OpenRGB || die
ln -s "${ESYSROOT}/usr/include/OpenRGB" . || die
sed -e '/^GIT_/d' -i *.pro || die
# Because of -Wl,--export-dynamic in app-misc/openrgb, this resources.qrc
# conflicts with the openrgb's one. So rename it.
sed -e 's/resources.qrc/resources_visualmap_plugin.qrc/' -i *.pro || die
mv --no-clobber resources.qrc resources_visualmap_plugin.qrc || die
}
src_configure() {
eqmake5 \
INCLUDEPATH+="${ESYSROOT}/usr/include/nlohmann"
}
src_install() {
exeinto /usr/$(get_libdir)/OpenRGB/plugins
doexe libOpenRGBVisualMapPlugin.so.1.0.0
}