You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-portage/fetchcommandwrapper/fetchcommandwrapper-0.8.4-r...

25 lines
630 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..12} )
inherit distutils-r1 pypi
DESCRIPTION="Wrapper integrating aria2 into portage's FETCHCOMMAND"
HOMEPAGE="https://github.com/hartwork/fetchcommandwrapper"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
RDEPEND=">=net-misc/aria2-1.10.2[metalink,xmlrpc]"
pkg_postinst() {
ewarn 'You need to append'
ewarn ' source /usr/share/fetchcommandwrapper/make.conf'
ewarn 'to /etc/portage/make.conf in order to integrate fetchcommandwrapper.'
}