You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-portage/portpeek/portpeek-3.2.4.ebuild

30 lines
713 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
PYTHON_COMPAT=( python3_{9,10,11,12} )
inherit python-r1
DESCRIPTION="A helper program for maintaining the package.keyword and package.unmask files"
HOMEPAGE="https://github.com/mpagano/portpeek"
SRC_URI="https://github.com/mpagano/portpeek/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 arm arm64 ppc sparc x86"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="${PYTHON_DEPS}"
RDEPEND="${DEPEND}
>=app-portage/gentoolkit-0.6.3
|| (
>=sys-apps/portage-3.0.54-r1[${PYTHON_USEDEP}]
)"
src_install() {
python_foreach_impl python_doscript ${PN}
doman *.[0-9]
}