You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/docx2txt/docx2txt-1.4.ebuild

25 lines
570 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DESCRIPTION="Convert MS Office docx files to plain text"
HOMEPAGE="http://docx2txt.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tgz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ia64 ~ppc64 x86"
RDEPEND="app-arch/unzip
dev-lang/perl"
PATCHES=( "${FILESDIR}"/${PN}-1.1-paragraph-newline.patch )
src_compile() { :; }
src_install() {
newbin docx2txt.pl docx2txt
dodoc docx2txt.config README ChangeLog ToDo AUTHORS
}