You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/htmlinc/htmlinc-1.0_beta1-r2.ebuild

31 lines
576 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit flag-o-matic toolchain-funcs
DESCRIPTION="HTML Include System by Ulli Meybohm"
HOMEPAGE="http://www.meybohm.de/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc sparc x86 ~x86-linux ~ppc-macos"
S="${WORKDIR}/${PN}"
PATCHES=(
"${FILESDIR}"/${PN}-gcc3-gentoo.patch
"${FILESDIR}"/${P}-fix-build-system.patch
)
src_configure() {
tc-export CXX
append-cxxflags -Wall
}
src_install() {
dobin htmlinc
einstalldocs
}