You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/multitail/multitail-7.1.2.ebuild

63 lines
1.4 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake optfeature
DESCRIPTION="Tail with multiple windows"
HOMEPAGE="http://www.vanheusden.com/multitail/ https://github.com/folkertvanheusden/multitail/"
SRC_URI="https://github.com/folkertvanheusden/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="debug examples unicode"
RDEPEND="sys-libs/ncurses:=[unicode(+)?]"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${PN}-7.0.0-gentoo.patch
)
src_prepare() {
cmake_src_prepare
# cmake looks for licence.txt to install it, which does not exist in the package
cp LICENSE license.txt || die
}
src_configure() {
local mycmakeargs=(
-DUTF8_SUPPORT=$(usex unicode)
)
CMAKE_BUILD_TYPE=$(usex debug Debug)
cmake_src_configure
}
src_install() {
cmake_src_install
insinto /etc
doins multitail.conf
rm -rf "${ED}"/usr/{ect,etc} || die
rm -rf "${ED}"/usr/share/doc/multitail-VERSION=${PV} || die
local DOCS=( readme.txt thanks.txt )
local HTML_DOCS=( manual.html )
einstalldocs
if use examples; then
docompress -x /usr/share/doc/${PF}/examples
docinto examples
dodoc conversion-scripts/{colors-example.{pl,sh},convert-{geoip,simple}.pl}
fi
}
pkg_postinst() {
optfeature "send a buffer to the X clipboard" x11-misc/xclip
}