You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-text/restview/restview-3.0.0.ebuild

30 lines
574 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..11} )
inherit distutils-r1 pypi
DESCRIPTION="reStructuredText viewer"
HOMEPAGE="
https://mg.pov.lt/restview/
https://pypi.org/project/restview/
"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/docutils[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/readme-renderer[${PYTHON_USEDEP}]
"
DOCS=( README.rst CHANGES.rst )
distutils_enable_tests pytest