You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/app-vim/cctree/cctree-1.61-r2.ebuild

29 lines
794 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit vim-plugin
DESCRIPTION="vim plugin: Cscope based source-code browser and code flow analysis tool"
HOMEPAGE="https://sites.google.com/site/vimcctree/"
LICENSE="bufexplorer.vim"
KEYWORDS="amd64 x86"
VIM_PLUGIN_HELPFILES="${PN}.txt"
RDEPEND="dev-util/cscope"
src_prepare() {
# There's good documentation included with the script, but it's not
# in a helpfile. Since there's rather too much information to include
# in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
mkdir doc || die
sed -e '/" Name Of File/,/".\+Community/!d' -e 's/^" \?//' \
-e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\L\2.txt*/' \
ftplugin/${PN}.vim > doc/${PN}.txt || die
default
}