You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-db/pgcli/pgcli-4.0.1-r1.ebuild

55 lines
1.3 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="CLI for Postgres with auto-completion and syntax highlighting"
HOMEPAGE="https://www.pgcli.com https://github.com/dbcli/pgcli"
SRC_URI="https://github.com/dbcli/pgcli/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD MIT"
SLOT="0"
KEYWORDS="amd64 ~x86"
RDEPEND="
dev-python/click[${PYTHON_USEDEP}]
>=dev-python/cli-helpers-2.2.1[${PYTHON_USEDEP}]
dev-python/configobj[${PYTHON_USEDEP}]
dev-python/pgspecial[${PYTHON_USEDEP}]
dev-python/prompt-toolkit[${PYTHON_USEDEP}]
dev-python/psycopg:0[${PYTHON_USEDEP}]
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/setproctitle[${PYTHON_USEDEP}]
dev-python/sqlparse[${PYTHON_USEDEP}]
dev-python/sshtunnel[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-db/postgresql
dev-python/mock[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
PATCHES=(
# https://github.com/dbcli/pgcli/pull/1452
"${FILESDIR}/${P}-no-pendulum.patch"
)
python_test() {
local EPYTEST_DESELECT=(
# hang while trying to create a keyring
# https://bugs.gentoo.org/925085
tests/test_main.py::test_pg_service_file
tests/test_ssh_tunnel.py::test_ssh_tunnel
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
epytest
}