You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-dotnet/monocalendar/monocalendar-0.7.2.ebuild

31 lines
634 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit mono wrapper
DESCRIPTION="iCal clone for .NET"
HOMEPAGE="http://www.monocalendar.com/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${PN}-source-${PV}.tar.gz"
S="${WORKDIR}/MonoCalendar"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 x86"
DEPEND=">=dev-lang/mono-1.2.1"
RDEPEND="${DEPEND}"
src_compile() {
emake -C bin/Release
}
src_install() {
exeinto /usr/$(get_libdir)/${PN}
doexe bin/Release/*dll
doexe bin/Release/*.exe
make_wrapper monocalendar "mono /usr/$(get_libdir)/${PN}/MonoCalendar.exe"
}