You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-embedded/mspdebug/mspdebug-0.25-r1.ebuild

34 lines
791 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="A free debugger for use with MSP430 MCUs"
HOMEPAGE="https://dlbeer.co.nz/mspdebug/ https://github.com/dlbeer/mspdebug"
SRC_URI="https://github.com/dlbeer/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE="readline"
DEPEND="readline? ( sys-libs/readline:0= )
virtual/libusb:0"
RDEPEND="${DEPEND}"
src_prepare() {
default
sed -i "s:-O1 \(.*\) -ggdb:\1:" Makefile || die
}
src_compile() {
emake CC="$(tc-getCC)" LIBDIR=/usr/$(get_libdir) $(usex readline "" "WITHOUT_READLINE=1")
}
src_install() {
emake DESTDIR="${ED}" LIBDIR=/usr/$(get_libdir) PREFIX=/usr install
einstalldocs
}