You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-embedded/xa/xa-2.4.0.ebuild

32 lines
565 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit toolchain-funcs
DESCRIPTION="High-speed, two-pass portable 6502 cross-assembler"
HOMEPAGE="https://www.floodgap.com/retrotech/xa/"
SRC_URI="https://www.floodgap.com/retrotech/xa/dists/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 x86"
PATCHES=(
"${FILESDIR}"/${PN}-2.4.0-make.patch
)
src_configure() {
tc-export CC
}
src_test() {
emake -j1 test
}
src_install() {
emake DESTDIR="${ED}"/usr install
einstalldocs
}