You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/ansi-wl-pprint/ansi-wl-pprint-1.0.2.ebuild

38 lines
981 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0.9999
#hackport: flags: example:examples
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="The Wadler/Leijen Pretty Printer for colored ANSI terminal output"
HOMEPAGE="https://github.com/ekmett/ansi-wl-pprint"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="examples"
RDEPEND="
>=dev-haskell/prettyprinter-compat-ansi-wl-pprint-1.0.2:=[profile?] <dev-haskell/prettyprinter-compat-ansi-wl-pprint-1.0.3:=[profile?]
>=dev-lang/ghc-8.10.6:=
examples? (
dev-haskell/ansi-terminal:=[profile?]
dev-haskell/prettyprinter:=[profile?]
dev-haskell/prettyprinter-ansi-terminal:=[profile?]
dev-haskell/text:=[profile?]
)
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.2.1.0
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag examples example)
}