You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/assoc/assoc-1.1.ebuild

33 lines
702 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.2.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="swap and assoc: Symmetric and Semigroupy Bifunctors"
HOMEPAGE="https://hackage.haskell.org/package/assoc"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+tagged"
RDEPEND="
>=dev-lang/ghc-8.8.1:=
tagged? (
>=dev-haskell/tagged-0.8.6:=[profile?] <dev-haskell/tagged-0.9:=[profile?]
)
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag tagged tagged)
}