You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/cabal/cabal-3.6.3.0.ebuild

35 lines
833 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.2.2.9999
#hackport: flags: -parsec-struct-diff
CABAL_PN="Cabal"
CABAL_FEATURES="lib profile haddock hoogle hscolour"
CABAL_FEATURES+=" nocabaldep" # in case installed Cabal is broken
inherit haskell-cabal
DESCRIPTION="A framework for packaging Haskell software"
HOMEPAGE="https://www.haskell.org/cabal/"
LICENSE="BSD"
SLOT="0/${PV}"
# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
RDEPEND="
>=dev-lang/ghc-9.2.4:= <dev-lang/ghc-9.3:=
"
DEPEND="${RDEPEND}
"
src_configure() {
haskell-cabal_src_configure \
--flag=-parsec-struct-diff
}
CABAL_CORE_LIB_GHC_PV="9.2.4 9.2.5 9.2.6 9.2.7 9.2.8"