You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/foundation/foundation-0.0.30.ebuild

36 lines
840 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0.9999
#hackport: flags: -doctest,-minimal-deps,-bench-all,-bounds-check,-linktest
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Alternative prelude with batteries and no dependencies"
HOMEPAGE="https://github.com/haskell-foundation/foundation"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE="experimental"
RDEPEND=">=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
~dev-haskell/basement-0.0.16
>=dev-haskell/cabal-3.0.0.0
"
src_configure() {
haskell-cabal_src_configure \
--flag=-bench-all \
--flag=-bounds-check \
--flag=-doctest \
$(cabal_flag experimental experimental) \
--flag=-linktest \
--flag=-minimal-deps
}