You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/gtk2hs-buildtools/gtk2hs-buildtools-0.13.10.0...

34 lines
802 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.2.0.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Tools to build the Gtk2Hs suite of User Interface libraries"
HOMEPAGE="https://projects.haskell.org/gtk2hs/"
LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+closuresignals"
RDEPEND=">=dev-haskell/cabal-1.24.0.0:=[profile?]
dev-haskell/hashtables:=[profile?]
dev-haskell/random:=[profile?]
>=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/alex-3.0.1
>=dev-haskell/cabal-3.0.0.0
>=dev-haskell/happy-1.18.9
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag closuresignals closuresignals)
}