You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/hdbc/hdbc-2.4.0.3.ebuild

53 lines
1.1 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.6.1.9999
#hackport: flags: buildtests:test
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
MY_PN="HDBC"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="Haskell Database Connectivity"
HOMEPAGE="https://github.com/hdbc/hdbc"
SRC_URI="https://hackage.haskell.org/package/${MY_P}/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RESTRICT="test" # Requires unmaintaned dev-haskell/testpack
CABAL_CHDEPS=(
'time >= 1.5 && < 1.10' 'time >= 1.5'
)
RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
dev-haskell/mtl:=[profile?]
dev-haskell/old-locale:=[profile?]
dev-haskell/old-time:=[profile?]
dev-haskell/text:=[profile?]
dev-haskell/utf8-string:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
S="${WORKDIR}/${MY_P}"
src_configure() {
config_flags=(
--flag=-buildtests
--flag=splitBase
--flag=minTime15
)
haskell-cabal_src_configure ${config_flags[@]}
}