You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/hspec-discover/hspec-discover-2.10.6.ebuild

36 lines
889 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.3.0
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Automatically discover and run Hspec tests"
HOMEPAGE="https://hspec.github.io/"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? (
~dev-haskell/hspec-meta-2.10.5
>=dev-haskell/mockery-0.3.5
>=dev-haskell/quickcheck-2.7
)
"
pkg_pretend() {
if use test; then
ewarn "The \"test\" USE flag for this package creates cycles within the"
ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
ewarn "It is recommended to leave it disabled unless explicitly testing the package."
fi
}