You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/httpd-shed/httpd-shed-0.4.1.1-r1.ebuild

35 lines
977 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.6.1.9999
#hackport: flags: +network-uri,+network-bsd
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="A simple web-server with an interact style API"
HOMEPAGE="https://hackage.haskell.org/package/httpd-shed"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="buildexamples"
RDEPEND=">=dev-lang/ghc-7.4.1:=
>=dev-haskell/network-2.3:=[profile?] <dev-haskell/network-3.2:=[profile?]
>=dev-haskell/network-bsd-2.7:=[profile?] <dev-haskell/network-bsd-2.9:=[profile?]
>=dev-haskell/network-uri-2.6:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag buildexamples buildexamples) \
--flag=network-bsd \
--flag=network-uri
}