You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/nanospec/nanospec-0.2.2.ebuild

36 lines
887 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.0.0.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="A lightweight implementation of a subset of Hspec's API"
HOMEPAGE="https://github.com/hspec/nanospec#readme"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND="
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? (
>=dev-haskell/hspec-1.3
>=dev-haskell/silently-1.2.4
)
"
pkg_pretend() {
if use test; then
ewarn "The \"test\" USE flag for this package creates cycles within the"
ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
ewarn "It is recommended to leave it disabled unless explicitly testing the package."
fi
}