You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/parallel-io/parallel-io-0.3.5.ebuild

34 lines
869 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.6.7.9999
#hackport: flags: -tests,-fuzz,-benchmark
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Combinators for executing IO actions in parallel on a thread pool"
HOMEPAGE="https://batterseapower.github.io/parallel-io/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">dev-haskell/extensible-exceptions-0.1.0.1:=[profile?]
>=dev-haskell/random-1.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
--flag=-benchmark \
--flag=-fuzz \
--flag=-tests
}