You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/parsec/parsec-3.1.14.0-r2.ebuild

42 lines
1.2 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.0.0.9999
CABAL_HACKAGE_REVISION=4
CABAL_FEATURES="lib profile haddock hoogle hscolour" # Circular depends: test-suite
# break circular dependencies:
# https://github.com/gentoo-haskell/gentoo-haskell/issues/810
CABAL_FEATURES+=" nocabaldep"
inherit haskell-cabal
DESCRIPTION="Monadic parser combinators"
HOMEPAGE="https://github.com/haskell/parsec"
LICENSE="BSD"
SLOT="0/${PV}"
# Keep in sync with relevant ghc versions (CABAL_CORE_LIB_GHC_PV)
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
RESTRICT=test # circular dependencies: dev-haskell/base-orphans->cabal->parsec[test]->test-framework-hunit->test-framework->base-orphans
CABAL_CHDEPS=(
'base >= 4.5.0 && < 4.16' 'base >= 4.5.0'
)
RDEPEND="
>=dev-lang/ghc-8.10.6:=
"
DEPEND="${RDEPEND}
"
# test? (
# >=dev-haskell/test-framework-0.8 <dev-haskell/test-framework-0.9
# >=dev-haskell/test-framework-hunit-0.3 <dev-haskell/test-framework-hunit-0.4
# >=dev-haskell/hunit-1.6 <dev-haskell/hunit-1.7
# )
CABAL_CORE_LIB_GHC_PV="8.8.4 8.10.4 8.10.5 8.10.6 8.10.7 9.0.1 9.0.2 PM:9999"