You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/quickcheck/quickcheck-2.14.3.ebuild

37 lines
957 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0.9999
#hackport: flags: +base4,-base3,-old-random,templatehaskell:template-haskell
CABAL_PN="QuickCheck"
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Automatic testing of Haskell programs"
HOMEPAGE="https://github.com/nick8325/quickcheck"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
IUSE="+template-haskell"
RDEPEND=">=dev-haskell/random-1.2.0:=[profile?] <dev-haskell/random-1.3:=[profile?]
>=dev-haskell/splitmix-0.1:=[profile?] <dev-haskell/splitmix-0.2:=[profile?]
>=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
"
src_configure() {
haskell-cabal_src_configure \
--flag=-base3 \
--flag=base4 \
--flag=-old-random \
$(cabal_flag template-haskell templatehaskell)
}