You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/regex-posix/regex-posix-0.96.0.0.ebuild

39 lines
947 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0.9999
#hackport: flags: +newbase,+splitbase,-_regex-posix-clib
CABAL_HACKAGE_REVISION=2
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Replaces/Enhances Text.Regex"
HOMEPAGE="https://hackage.haskell.org/package/regex-posix"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND=">=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/regex-base-0.94:=[profile?] <dev-haskell/regex-base-0.95:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.12
"
CABAL_CHDEPS=(
'base >= 4.3 && < 4.16' 'base >= 4.3'
)
src_configure() {
haskell-cabal_src_configure \
--flag=-_regex-posix-clib \
--flag=newbase \
--flag=splitbase
}