You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/resource-pool/resource-pool-0.2.3.2.ebuild

36 lines
880 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.6.6.9999
#hackport: flags: -developer
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="A high-performance striped resource pooling implementation"
HOMEPAGE="https://github.com/bos/pool"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RDEPEND="dev-haskell/hashable:=[profile?]
>=dev-haskell/monad-control-0.2.0.1:=[profile?]
>=dev-haskell/stm-2.3:=[profile?]
>=dev-haskell/transformers-base-0.4:=[profile?]
>=dev-haskell/vector-0.7:=[profile?]
>=dev-lang/ghc-7.8.2:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.18.1.3
"
src_configure() {
haskell-cabal_src_configure \
--flag=-developer
}