You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/retry/retry-0.9.0.0.ebuild

39 lines
927 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.9999
#hackport: flags: -lib-werror
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Retry combinators for monadic actions that may fail"
HOMEPAGE="https://github.com/Soostone/retry"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-haskell/exceptions-0.5:=[profile?]
>=dev-haskell/random-1:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/hedgehog
>=dev-haskell/hunit-1.2.5.2
dev-haskell/mtl
dev-haskell/stm
dev-haskell/tasty
dev-haskell/tasty-hedgehog
dev-haskell/tasty-hunit )
"
src_configure() {
haskell-cabal_src_configure \
--flag=-lib-werror
}