You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/strict/strict-0.5.ebuild

38 lines
956 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.2.1.9999
#hackport: flags: +assoc
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Strict data types and String IO"
HOMEPAGE="https://github.com/haskell-strict/strict"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND="
>=dev-haskell/assoc-1.1:=[profile?] <dev-haskell/assoc-1.2:=[profile?]
>=dev-haskell/hashable-1.2.7.0:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
>=dev-haskell/these-1.2:=[profile?] <dev-haskell/these-1.3:=[profile?]
>=dev-lang/ghc-8.8.1:=
|| (
( >=dev-haskell/text-1.2.3.0 <dev-haskell/text-1.3 )
( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 )
)
dev-haskell/text:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
"
src_configure() {
haskell-cabal_src_configure \
--flag=assoc
}