You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-...

40 lines
1.1 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.5.6.9999
#hackport: flags: +base4
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="QuickCheck2 support for the test-framework package"
HOMEPAGE="http://haskell.github.io/test-framework/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE=""
RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2.0:=[profile?]
>=dev-haskell/quickcheck-2.4:=[profile?]
>=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.3:=[profile?]
>=dev-haskell/test-framework-0.8:=[profile?] <dev-haskell/test-framework-0.9:=[profile?]
>=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.10
"
CABAL_CHDEPS=(
'QuickCheck >= 2.4 && < 2.13' 'QuickCheck >= 2.4' \
'random >= 1 && < 1.2' 'random >= 1'
)
src_configure() {
haskell-cabal_src_configure \
--flag=base4
}