You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/text-icu/text-icu-0.8.0.2.ebuild

37 lines
935 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0
CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
inherit haskell-cabal
DESCRIPTION="Bindings to the ICU library"
HOMEPAGE="https://github.com/haskell/text-icu"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
RESTRICT=test # QuickCheck occasionally finds counterexamples
# and fails to build: Duplicate instance declarations: instance NFData Ordering
RDEPEND=">=dev-haskell/text-0.9.1.0:=[profile?]
>=dev-lang/ghc-8.8.1:=
dev-libs/icu
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
"
# test? ( >=dev-haskell/hunit-1.2
# >=dev-haskell/quickcheck-2.4
# dev-haskell/random
# >=dev-haskell/test-framework-0.4
# >=dev-haskell/test-framework-hunit-0.2
# >=dev-haskell/test-framework-quickcheck2-0.2
# dev-haskell/text )
# "