You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/text-short/text-short-0.1.5-r1.ebuild

44 lines
1.1 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.2.1.9999
#hackport: flags: asserts:debug
CABAL_HACKAGE_REVISION=2
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Memory-efficient representation of Unicode text strings"
HOMEPAGE="https://hackage.haskell.org/package/text-short"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="debug"
RDEPEND="
>=dev-haskell/hashable-1.2.6:=[profile?] <dev-haskell/hashable-1.5:=[profile?]
>=dev-lang/ghc-8.8.1:=
|| (
( >=dev-haskell/text-1.0 <dev-haskell/text-1.3 )
( >=dev-haskell/text-2.0 <dev-haskell/text-2.1 )
)
dev-haskell/text:=[profile?]
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
test? (
>=dev-haskell/tasty-1.4 <dev-haskell/tasty-1.5
>=dev-haskell/tasty-hunit-0.10.0 <dev-haskell/tasty-hunit-0.11
>=dev-haskell/tasty-quickcheck-0.10 <dev-haskell/tasty-quickcheck-0.11
)
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag debug asserts)
}